ETSI TS 103 479 V1.3.1 (2025-09)
Emergency Communications (EMTEL); Core elements for network independent access to emergency services
Emergency Communications (EMTEL); Core elements for network independent access to emergency services
RTS/EMTEL-00076
General Information
Standards Content (Sample)
TECHNICAL SPECIFICATION
Emergency Communications (EMTEL);
Core elements for network independent access
to emergency services
2 ETSI TS 103 479 V1.3.1 (2025-09)
Reference
RTS/EMTEL-00076
Keywords
emergency services, location, multimedia
ETSI
650 Route des Lucioles
F-06921 Sophia Antipolis Cedex - FRANCE
Tel.: +33 4 92 94 42 00 Fax: +33 4 93 65 47 16
Siret N° 348 623 562 00017 - APE 7112B
Association à but non lucratif enregistrée à la
Sous-Préfecture de Grasse (06) N° w061004871
Important notice
The present document can be downloaded from the
ETSI Search & Browse Standards application.
The present document may be made available in electronic versions and/or in print. The content of any electronic and/or
print versions of the present document shall not be modified without the prior written authorization of ETSI. In case of any
existing or perceived difference in contents between such versions and/or in print, the prevailing version of an ETSI
deliverable is the one made publicly available in PDF format on ETSI deliver repository.
Users should be aware that the present document may be revised or have its status changed,
this information is available in the Milestones listing.
If you find errors in the present document, please send your comments to
the relevant service listed under Committee Support Staff.
If you find a security vulnerability in the present document, please report it through our
Coordinated Vulnerability Disclosure (CVD) program.
Notice of disclaimer & limitation of liability
The information provided in the present deliverable is directed solely to professionals who have the appropriate degree of
experience to understand and interpret its content in accordance with generally accepted engineering or
other professional standard and applicable regulations.
No recommendation as to products and services or vendors is made or should be implied.
No representation or warranty is made that this deliverable is technically accurate or sufficient or conforms to any law
and/or governmental rule and/or regulation and further, no representation or warranty is made of merchantability or fitness
for any particular purpose or against infringement of intellectual property rights.
In no event shall ETSI be held liable for loss of profits or any other incidental or consequential damages.
Any software contained in this deliverable is provided "AS IS" with no warranties, express or implied, including but not
limited to, the warranties of merchantability, fitness for a particular purpose and non-infringement of intellectual property
rights and ETSI shall not be held liable in any event for any damages whatsoever (including, without limitation, damages
for loss of profits, business interruption, loss of information, or any other pecuniary loss) arising out of or related to the use
of or inability to use the software.
Copyright Notification
No part may be reproduced or utilized in any form or by any means, electronic or mechanical, including photocopying and
microfilm except as authorized by written permission of ETSI.
The content of the PDF version shall not be modified without the written authorization of ETSI.
The copyright and the foregoing restriction extend to reproduction in all media.
© ETSI 2025.
All rights reserved.
ETSI
3 ETSI TS 103 479 V1.3.1 (2025-09)
Contents
Intellectual Property Rights . 7
Foreword . 7
Modal verbs terminology . 7
Executive summary . 7
Introduction . 8
1 Scope . 9
2 References . 9
2.1 Normative references . 9
2.2 Informative references . 12
3 Definition of terms, symbols and abbreviations . 13
3.1 Terms . 13
3.2 Symbols . 13
3.3 Abbreviations . 13
4 General . 15
4.1 Overview . 15
4.2 Architecture . 15
4.3 Mandatory Interfaces . 16
4.4 Optional Interfaces . 18
5 Entities . 18
5.1 Border Control Function (BCF) . 18
5.1.1 General . 18
5.1.2 Mandatory Interfaces . 19
5.1.3 Optional Interfaces . 19
5.2 Emergency Service Routing Proxy (ESRP) . 19
5.2.1 General . 19
5.2.2 Mandatory Interfaces . 20
5.2.3 Optional Interfaces . 21
5.2.4 Call Queueing . 21
5.2.5 Policy Routing . 22
5.2.6 Identity Verification . 23
5.3 Emergency Call Routing Function (ECRF) . 23
5.3.1 General . 23
5.3.2 Mandatory Interfaces . 23
5.3.3 Optional Interfaces . 24
5.3.4 Routing Query . 24
5.3.5 Service Boundary . 24
5.3.6 Forest Guide. 25
5.3.6.1 General . 25
5.3.6.2 NAPTR Resource Records . 25
5.4 Public Safety Answering Point (PSAP). 25
5.4.1 General . 25
5.4.2 Mandatory Interfaces . 26
5.4.3 Optional Interfaces . 26
5.5 Location Information Server (LIS) . 27
5.5.1 General . 27
5.5.2 Mandatory Interfaces . 28
5.5.3 Optional Interfaces . 28
5.5.4 Location Representation . 28
5.6 Call Transfer Bridge (BRIDGE) . 29
5.6.1 General . 29
5.6.2 Mandatory Interfaces . 29
5.6.3 Optional Interfaces . 30
ETSI
4 ETSI TS 103 479 V1.3.1 (2025-09)
5.7 Outbound Call Interface Function (OCIF) . 30
5.7.1 General . 30
5.7.2 Mandatory Interfaces . 30
5.7.3 Optional Interfaces . 31
6 Interfaces . 31
6.1 Signalling . 31
6.1.1 SIP Transport (SIP-1) . 31
6.1.2 SIP Session (SIP-2) . 31
6.1.2.1 General . 31
6.1.2.2 SIP Methods . 32
6.1.2.3 Required SIP Headers . 35
6.1.2.4 Accepted SIP Headers . 36
6.1.2.5 Resource Priority and Priority . 36
6.1.2.6 History-Info and Reason . 37
6.1.2.7 Call-Info . 37
6.1.2.8 SIP Message Bodies . 38
6.1.2.9 SIP Element Overload . 38
6.1.2.10 Test Call . 39
6.1.2.11 Media and Language Negotiation . 39
6.1.3 SIP Registration (SIP-3) . 40
6.1.3.1 General . 40
6.1.3.2 SIP Methods . 40
6.1.3.3 Required SIP Headers . 40
6.1.4 SIP Location Refresh (SIP-4) . 40
6.1.4.1 General . 40
6.1.4.2 SIP Method . 40
6.1.4.3 Required SIP Headers . 41
6.1.4.4 Location Refresh . 41
6.2 Web Services . 41
6.2.1 Dequeue Registration (HTTP-1) . 41
6.2.1.1 General . 41
6.2.1.2 Parameter . 42
6.2.1.3 Transport Layer Security . 42
6.2.2 Bad Actor (HTTP-2) . 43
6.2.2.1 General . 43
6.2.2.2 Parameter . 43
6.2.2.3 Transport Layer Security . 43
6.2.3 Signing and Verification (HTTP-3) . 43
6.2.3.1 General . 43
6.2.3.2 Parameter . 44
6.2.3.3 Transport Layer Security . 46
6.3 Event Notification . 46
6.3.1 Queue State (SIP-E1) . 46
6.3.1.1 General . 46
6.3.1.2 Parameter . 47
6.3.2 Abandoned Call (SIP-E2) . 48
6.3.2.1 General . 48
6.3.2.2 Parameter . 48
6.3.3 Security Posture (SIP-E3) . 49
6.3.3.1 General . 49
6.3.3.2 Parameter . 49
6.3.4 Element State (SIP-E4) . 50
6.3.4.1 General . 50
6.3.4.2 Parameter . 50
6.3.5 Service State (SIP-E5) . 51
6.3.5.1 General . 51
6.3.5.2 Parameter . 51
6.4 Mapping Services . 52
6.4.1 Find Service (LOST-1) . 52
6.4.1.1 General . 52
6.4.1.2 findService Request . 53
ETSI
5 ETSI TS 103 479 V1.3.1 (2025-09)
6.4.1.3 findService Response . 53
6.4.1.4 Transport Layer Security . 54
6.4.2 Service Boundary (LOST-2) . 54
6.4.2.1 General . 54
6.4.2.2 getServiceBoundary Request . 54
6.4.2.3 getServiceBoundary Response . 55
6.4.2.4 Transport Layer Security . 55
6.4.3 List Services (LOST-3) . 55
6.4.3.1 General . 55
6.4.3.2 listServices Request . 55
6.4.3.3 listServices Response . 55
6.4.3.4 Transport Layer Security . 55
6.4.4 List Services by Location (LOST-4) . 55
6.4.4.1 General . 55
6.4.4.2 listServicesByLocation Request . 56
6.4.4.3 listServicesByLocation Response . 56
6.4.4.4 Transport Layer Security . 56
6.4.5 Error Responses . 56
6.5 Location Services . 57
6.5.1 HTTP Enabled Location Delivery (HELD-1) . 57
6.5.1.1 General . 57
6.5.1.2 Location Request . 57
6.5.1.3 Location Response . 57
6.5.1.4 Error Responses . 57
6.5.1.5 Transport Layer Security . 57
6.5.2 Location Dereference (HELD-2) . 57
6.5.3 Location URI (HELD-3) . 57
6.5.3.1 General . 57
6.5.3.2 Subscription . 57
6.5.3.3 Notification . 58
6.6 Media . 58
6.6.1 RTP Transport (RTP-1) . 58
6.6.2 RTP Types (RTP-2) . 58
6.6.2.1 General . 58
6.6.2.2 Audio . 58
6.6.2.3 Video . 58
6.6.2.4 Real-time Text . 59
6.7 Instant Messaging (IM-1) . 59
6.8 Common Alerting Protocol (CAP-1) . 59
Annex A (normative): JSON Schema . 60
A.1 QueueState . 60
A.2 AbandonedCall . 60
A.3 SecurityPosture . 61
A.4 ElementState . 62
A.5 ServiceState . 62
A.6 Dequeue Registration Request . 63
A.7 Dequeue Registration Response . 63
A.8 BadActor Service . 64
A.9 BadActor Response . 64
Annex B (informative): Organizational Descriptions . 65
B.0 General . 65
B.1 Certificate Authority. 65
ETSI
6 ETSI TS 103 479 V1.3.1 (2025-09)
B.2 National, and Regional Authorities . 65
B.3 Public Safety Computer Emergency Response Team (CERT) . 65
B.4 ETSI Protocol Naming and Numbering Service (PNNS) . 65
B.5 Emergency Call Service Authorities . 65
Annex C (informative): Parameter Registries . 67
C.0 General . 67
C.1 queueState Registry . 67
C.1.1 General . 67
C.1.2 Name . 67
C.1.3 Information required to create a new value . 67
C.1.4 Management Policy . 67
C.1.5 Content . 67
C.1.6 Initial Values . 67
C.2 securityPosture Registry . 68
C.2.0 General . 68
C.2.1 Name . 68
C.2.2 Information required to create a new value . 68
C.2.3 Management Policy . 68
C.2.4 Content . 68
C.2.5 Initial Values . 68
C.3 elementState Registry . 68
C.3.0 General . 68
C.3.1 Name . 68
C.3.2 Information required to create a new value . 68
C.3.3 Management Policy . 69
C.3.4 Content . 69
C.3.5 Initial Values . 69
C.4 serviceState Registry . 69
C.4.0 General . 69
C.4.1 Name . 69
C.4.2 Information required to create a new value . 69
C.4.3 Management Policy . 69
C.4.4 Content . 69
C.4.5 Initial Values . 69
C.5 Cipher Suites . 70
C.5.0 General . 70
C.5.1 Recommended TLS 1.3 Cipher Suites . 70
C.5.2 Acceptable TLS 1.2 Cipher Suites . 70
Annex D (informative): Change history . 71
History . 72
ETSI
7 ETSI TS 103 479 V1.3.1 (2025-09)
Intellectual Property Rights
Essential patents
IPRs essential or potentially essential to normative deliverables may have been declared to ETSI. The declarations
pertaining to these essential IPRs, if any, are publicly available for ETSI members and non-members, and can be
found in ETSI SR 000 314: "Intellectual Property Rights (IPRs); Essential, or potentially Essential, IPRs notified to
ETSI in respect of ETSI standards", which is available from the ETSI Secretariat. Latest updates are available on the
ETSI IPR online database.
Pursuant to the ETSI Directives including the ETSI IPR Policy, no investigation regarding the essentiality of IPRs,
including IPR searches, has been carried out by ETSI. No guarantee can be given as to the existence of other IPRs not
referenced in ETSI SR 000 314 (or the updates on the ETSI Web server) which are, or may be, or may become,
essential to the present document.
Trademarks
The present document may include trademarks and/or tradenames which are asserted and/or registered by their owners.
ETSI claims no ownership of these except for any which are indicated as being the property of ETSI, and conveys no
right to use or reproduce any trademark and/or tradename. Mention of those trademarks in the present document does
not constitute an endorsement by ETSI of products, services or organizations associated with those trademarks.
DECT™, PLUGTESTS™, UMTS™ and the ETSI logo are trademarks of ETSI registered for the benefit of its
Members. 3GPP™, LTE™ and 5G™ logo are trademarks of ETSI registered for the benefit of its Members and of the
3GPP Organizational Partners. oneM2M™ logo is a trademark of ETSI registered for the benefit of its Members and of ®
the oneM2M Partners. GSM and the GSM logo are trademarks registered and owned by the GSM Association.
Foreword
This Technical Specification (TS) has been produced by ETSI Special Committee Emergency Communications
(EMTEL).
Modal verbs terminology
In the present document "shall", "shall not", "should", "should not", "may", "need not", "will", "will not", "can" and
"cannot" are to be interpreted as described in clause 3.2 of the ETSI Drafting Rules (Verbal forms for the expression of
provisions).
"must" and "must not" are NOT allowed in ETSI deliverables except when used in direct citation.
Executive summary
The core elements for network independent access to emergency services provide facilities that support centralized
mapping and routing functions for current and future emergency communications and operational requirements. The
baseline is a network with the functional elements that comprise security measures and the routing capabilities being
necessary to forward a call received at any concentration point based on the caller's location to the responsible
emergency call centre. In addition, other functional elements and necessary protocols and procedures enabling
interoperable and secure implementations are specified to allow multimedia communications as they evolve.
ETSI
8 ETSI TS 103 479 V1.3.1 (2025-09)
Introduction
At present, an emergency services infrastructure is based on straightforward technical building blocks and a few
legal/regulatory aspects. Technical elements, typically part of an incumbent telephone service provider, ensure that
emergency calls are routed to the most appropriate PSAP. Such routing is based on static information at the local
telephone exchange that provides a mapping between the location of a calling line and the PSAP, or for a mobile call,
between the location of the mobile network cell coverage and the PSAP. The mapping information itself is most often
managed by the national regulator, and typically, mapping information is represented by dialling code/area code/cell
identifier and a table that maps those codes to PSAPs, which are identified by unlisted and often un-dialable numbers.
However, the existing, legacy emergency services infrastructure is not designed in a way that enables interaction with
enhanced services, or that current and future communications and operational requirements will be met. Simply put, the
emergency services infrastructure has not kept up with technology, thus, is not able to provide the level of service that
citizens expect. Hence, new technologies with a new architecture are introduced as core elements for network
independent access to emergency services. These elements enable citizens/individuals to contact emergency services in
different ways, using the same types of technology as those they use to communicate every day. It also makes possible
that PSAPs receive more and better information about emergencies of all magnitudes and improves interoperability
between emergency services.
ETSI
9 ETSI TS 103 479 V1.3.1 (2025-09)
1 Scope
The present document describes the architecture, the core elements and corresponding technical interfaces for network
independent access to emergency services. Elements are: Border Control Function (BCF), Emergency Service Routing
Proxy (ESRP), Emergency Call Routing Function (ECRF), Public Safety Answering Point (PSAP), the Location
Information Server (LIS), and the Call Transfer Bridge (BRIDGE).
The described architecture is currently named Next Generation 112 architecture.
2 References
2.1 Normative references
References are either specific (identified by date of publication and/or edition number or version number) or
non-specific. For specific references, only the cited version applies. For non-specific references, the latest version of the
referenced document (including any amendments) applies.
Referenced documents which are not found to be publicly available in the expected location might be found in the
ETSI docbox.
NOTE: While any hyperlinks included in this clause were valid at the time of publication, ETSI cannot guarantee
their long-term validity.
The following referenced documents are necessary for the application of the present document.
[1] ETSI ES 203 178: "Functional architecture to support European requirements on emergency caller
location determination and transport".
[2] ETSI ES 203 283: "Protocol specifications for Emergency Service Caller Location determination
and transport".
[3] ETSI TS 103 625: "Emergency Communications (EMTEL); Transporting Handset Location to
PSAPs for Emergency Communications - Advanced Mobile Location".
[4] IETF RFC 2046 (November 1996): "Multipurpose Internet Mail Extensions (MIME) Part Two:
Media Types", N. Freed and N. Borenstein.
[5] IETF RFC 3261 (June 2002): "SIP: Session Initiation Protocol", J. Rosenberg, H. Schulzrinne,
G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley and E. Schooler.
[6] IETF RFC 3262 (June 2002): "Reliability of Provisional Responses in Session Initiation Protocol
(SIP)", J. Rosenberg and H. Schulzrinne.
[7] IETF RFC 3264 (June 2002): "An Offer/Answer Model with Session Description Protocol (SDP)",
J. Rosenberg and H. Schulzrinne.
[8] IETF RFC 3311 (October 2002): "The Session Initiation Protocol (SIP) UPDATE Method",
J. Rosenberg.
[9] IETF RFC 3325 (November 2002): "Private Extensions to the Session Initiation Protocol (SIP) for
Asserted Identity Within Trusted Networks", C. Jennings, J. Peterson and M. Watson.
[10] IETF RFC 3326 (December 2002): "The Reason Header Field for the Session Initiation Protocol
(SIP)", D. Oran and G. Camarillo.
[11] IETF RFC 3428 (December 2002): "Session Initiation Protocol (SIP) Extension for Instant
Messaging", B. Campbell, J. Rosenberg, H. Schulzrinne, C. Huitema and D. Gurle.
[12] IETF RFC 3515 (July 2003): "The Session Initiation Protocol (SIP) Refer Method", R. Sparks.
ETSI
---------------------- P
...








Questions, Comments and Discussion
Ask us and Technical Secretary will try to provide an answer. You can facilitate discussion about the standard in here.
Loading comments...