Universal Mobile Telecommunications System (UMTS); LTE; Service capability exposure functionality over Ns reference point (3GPP TS 29.153 version 14.3.0 Release 14)

RTS/TSGC-0329153ve30

General Information

Status
Published
Publication Date
09-Oct-2019
Current Stage
12 - Completion
Completion Date
10-Oct-2019
Ref Project
Standard
ETSI TS 129 153 V14.3.0 (2019-10) - Universal Mobile Telecommunications System (UMTS); LTE; Service capability exposure functionality over Ns reference point (3GPP TS 29.153 version 14.3.0 Release 14)
English language
19 pages
sale 15% off
Preview
sale 15% off
Preview

Standards Content (Sample)


TECHNICAL SPECIFICATION
Universal Mobile Telecommunications System (UMTS);
LTE;
Service capability exposure
functionality over Ns reference point
(3GPP TS 29.153 version 14.3.0 Release 14)

3GPP TS 29.153 version 14.3.0 Release 14 1 ETSI TS 129 153 V14.3.0 (2019-10)

Reference
RTS/TSGC-0329153ve30
Keywords
LTE,UMTS
ETSI
650 Route des Lucioles
F-06921 Sophia Antipolis Cedex - FRANCE

Tel.: +33 4 92 94 42 00  Fax: +33 4 93 65 47 16

Siret N° 348 623 562 00017 - NAF 742 C
Association à but non lucratif enregistrée à la
Sous-Préfecture de Grasse (06) N° 7803/88

Important notice
The present document can be downloaded from:
http://www.etsi.org/standards-search
The present document may be made available in electronic versions and/or in print. The content of any electronic and/or
print versions of the present document shall not be modified without the prior written authorization of ETSI. In case of any
existing or perceived difference in contents between such versions and/or in print, the prevailing version of an ETSI
deliverable is the one made publicly available in PDF format at www.etsi.org/deliver.
Users of the present document should be aware that the document may be subject to revision or change of status.
Information on the current status of this and other ETSI documents is available at
https://portal.etsi.org/TB/ETSIDeliverableStatus.aspx
If you find errors in the present document, please send your comment to one of the following services:
https://portal.etsi.org/People/CommiteeSupportStaff.aspx
Copyright Notification
No part may be reproduced or utilized in any form or by any means, electronic or mechanical, including photocopying
and microfilm except as authorized by written permission of ETSI.
The content of the PDF version shall not be modified without the written authorization of ETSI.
The copyright and the foregoing restriction extend to reproduction in all media.

© ETSI 2019.
All rights reserved.
DECT™, PLUGTESTS™, UMTS™ and the ETSI logo are trademarks of ETSI registered for the benefit of its Members.

3GPP™ and LTE™ are trademarks of ETSI registered for the benefit of its Members and
of the 3GPP Organizational Partners.
oneM2M™ logo is a trademark of ETSI registered for the benefit of its Members and
of the oneM2M Partners. ®
GSM and the GSM logo are trademarks registered and owned by the GSM Association.
ETSI
3GPP TS 29.153 version 14.3.0 Release 14 2 ETSI TS 129 153 V14.3.0 (2019-10)
Intellectual Property Rights
Essential patents
IPRs essential or potentially essential to normative deliverables may have been declared to ETSI. The information
pertaining to these essential IPRs, if any, is publicly available for ETSI members and non-members, and can be found
in ETSI SR 000 314: "Intellectual Property Rights (IPRs); Essential, or potentially Essential, IPRs notified to ETSI in
respect of ETSI standards", which is available from the ETSI Secretariat. Latest updates are available on the ETSI Web
server (https://ipr.etsi.org/).
Pursuant to the ETSI IPR Policy, no investigation, including IPR searches, has been carried out by ETSI. No guarantee
can be given as to the existence of other IPRs not referenced in ETSI SR 000 314 (or the updates on the ETSI Web
server) which are, or may be, or may become, essential to the present document.
Trademarks
The present document may include trademarks and/or tradenames which are asserted and/or registered by their owners.
ETSI claims no ownership of these except for any which are indicated as being the property of ETSI, and conveys no
right to use or reproduce any trademark and/or tradename. Mention of those trademarks in the present document does
not constitute an endorsement by ETSI of products, services or organizations associated with those trademarks.
Legal Notice
This Technical Specification (TS) has been produced by ETSI 3rd Generation Partnership Project (3GPP).
The present document may refer to technical specifications or reports using their 3GPP identities. These shall be
interpreted as being references to the corresponding ETSI deliverables.
The cross reference between 3GPP and ETSI identities can be found under http://webapp.etsi.org/key/queryform.asp.
Modal verbs terminology
In the present document "shall", "shall not", "should", "should not", "may", "need not", "will", "will not", "can" and
"cannot" are to be interpreted as described in clause 3.2 of the ETSI Drafting Rules (Verbal forms for the expression of
provisions).
"must" and "must not" are NOT allowed in ETSI deliverables except when used in direct citation.
ETSI
3GPP TS 29.153 version 14.3.0 Release 14 3 ETSI TS 129 153 V14.3.0 (2019-10)
Contents
Intellectual Property Rights . 2
Legal Notice . 2
Modal verbs terminology . 2
Foreword . 4
1 Scope . 5
2 References . 5
3 Definitions and abbreviations . 6
3.1 Definitions . 6
3.2 Abbreviations . 6
4 Architectural Overview . 6
4.0 Overview . 6
4.1 Reference Model . 6
4.2 Functional ele me nts . 7
4.2.1 RCAF . 7
4.2.2 SCEF . 7
4.3 Procedures over the Ns reference point . 7
4.3.1 Network status reporting procedures . 7
4.3.1.1 General . 7
4.3.1.2 Request of one-time or continuous reporting of network status . 7
4.3.1.3 Continuous reporting of network status . 8
4.3.1.4 Cancellation of continuous reporting of network status . 8
4.3.2 RCAF selection . 9
5 Ns protocol . 9
5.1 Protocol support . 9
5.2 Initialization, maintenance and termination of connection and session. 9
5.3 Ns specific AVPs . 10
5.3.1 General . 10
5.3.2 Network-Congestion-Area-Report AVP . 10
5.3.3 Ns-Request-Type AVP . 10
5.4 Ns re-used AVPs . 10
5.4.1 General . 10
5.4.2 Use of the Supported-Features AVP on the Ns reference point . 11
5.5 Ns specific Experimental-Result-Code AVP values . 12
5.5.1 General . 12
5.5.2 Success . 12
5.5.3 Permanent Failures . 12
5.5.4 Transient Failures . 12
5.6 Ns messages . 12
5.6.1 Command-Code Values . 12
5.6.2 Network-Status-Request (NSR) command . 13
5.6.3 Network-Status-Answer (NSA) command . 13
5.6.4 Network-Status-Continuous-Report-Request (NCR) command . 14
5.6.5 Network-Status-Continuous-Report-Answer (NCA) command . 14
Annex A (informative): Call Flows over Ns . 15
A.1 Request of one time or continuous reporting of network status . 15
A.2 Continuous reporting of network status . 15
A.3 Cancellation of continuous reporting of network status . 16
Annex B (informative): Change history . 17
History . 18
ETSI
3GPP TS 29.153 version 14.3.0 Release 14 4 ETSI TS 129 153 V14.3.0 (2019-10)
Foreword
rd
This Technical Specification has been produced by the 3 Generation Partnership Project (3GPP).
The contents of the present document are subject to continuing work within the TSG and may change following formal
TSG approval. Should the TSG modify the contents of the present document, it will be re-released by the TSG with an
identifying change of release date and an increase in version number as follows:
Version x.y.z
where:
x the first digit:
1 presented to TSG for information;
2 presented to TSG for approval;
3 or greater indicates TSG approved document under change control.
y the second digit is incremented for all changes of substance, i.e. technical enhancements, corrections,
updates, etc.
z the third digit is incremented when editorial only changes have been incorporated in the document.
ETSI
3GPP TS 29.153 version 14.3.0 Release 14 5 ETSI TS 129 153 V14.3.0 (2019-10)
1 Scope
This document defines the protocol for Ns reference point between the Service Capability Exposure Function (SCEF)
and RAN Congestion Awareness Function (RCAF).
The Ns reference point and related stage 2 procedures are defined in 3GPP TS 23.682 [2].
2 References
The following documents contain provisions which, through reference in this text, constitute provisions of the present
document.
- References are either specific (identified by date of publication, edition number, version number, etc.) or
non-specific.
- For a specific reference, subsequent revisions do not apply.
- For a non-specific reference, the latest version applies. In the case of a reference to a 3GPP document (including
a GSM document), a non-specific reference implicitly refers to the latest version of that document in the same
Release as the present document.
[1] 3GPP TR 21.905: "Vocabulary for 3GPP Specifications".
[2] 3GPP TS 23.682: "Architecture enhancements to facilitate communications with packet data
networks and applications ".
[3] IETF RFC 3588: "Diameter Base Protocol".
[4] 3GPP TS 29.217: "Congestion reporting over Np reference point".
[5] IETF RFC 7683: "Diameter Overload Indication Conveyance".
[6] 3GPP TS 29.229: "Cx and Dx interfaces based on Diameter protocol; Protocol details".
[7] 3GPP TS 29.336: "Home Subscriber Server (HSS) diameter interfaces for interworking with
packet data networks and applications Diameter Base Protocol".
[8] 3GPP TS 29.154: "Service Capability Exposure Functionality over Nt reference point".
[9] 3GPP TS 29.274: "3GPP Evolved Packet System. Evolved GPRS Tunnelling Protocol for EPS
(GTPv2)".
[10] IETF RFC 5719: "Updated IANA Considerations for Diameter Command Code Allocations".
[11] IETF RFC 2234: "Augmented BNF for syntax specifications".
[12] 3GPP TS 29.213: "Policy and charging control signalling flows and Quality of Service (QoS)
parameter mapping".
[13] IETF RFC 7944: "Diameter Routing Message Priority".
[14] IETF RFC 8583: "Diameter Load Information Conveyance".
[15] IETF RFC 6733: "Diameter Base Protocol".
ETSI
3GPP TS 29.153 version 14.3.0 Release 14 6 ETSI TS 129 153 V14.3.0 (2019-10)
3 Definitions and abbreviations
3.1 Definitions
For the purposes of the present document, the terms and definitions given in 3GPP TR 21.905 [1] and the following
apply. A term defined in the present document takes precedence over the definition of the same term, if any, in
3GPP TR 21.905 [1].
3.2 Abbreviations
For the purposes of the present document, the abbreviations given in TR 21.905 [1] and the following apply. An
abbreviation defined in the present document takes precedence over the definition of the same abbreviation, if any, in
TR 21.905 [1].
AS Application Server
DRMP Diameter Routing Message Priority
NCA Network Status Continuous Report Answer
NCR Network Status Continuous Report Request
NSA Network Status Answer
NSR Network Status Request
RCAF RAN Congestion Awareness Function
SCEF Service Capability Exposure Function
SCS Service Capability Server
4 Architectural Overview
4.0 Overview
The Ns reference point is located between the RCAF and SCEF. The Ns reference point is used for network status
reporting.
The stage 2 level requirements for the Ns reference point are defined in 3GPP TS 23.682 [2].
Refer to Annex G of 3GPP TS 29.213 [12] for Diameter overload control procedures over the Ns reference point.
Refer to Annex J of 3GPP TS 29.213 [12] for Diameter message priority mechanism procedures over the Ns interface.
Refer to Annex K of 3GPP TS 29.213 [12] for Diameter load control procedures over the Ns reference point.
4.1 Reference Model
The Ns reference point is defined between the RCAF and the SCEF to transfer the network status. The relationship
between the two functional entities is depicted in figure 4.1.1. The complete 3GPP architecture for service capability
exposure is defined in 3GPP TS 23.682 [2].

Ns
SCEF
RCAF
Figure 4.1.1: Ns reference model
ETSI
3GPP TS 29.153 version 14.3.0 Release 14 7 ETSI TS 129 153 V14.3.0 (2019-10)
4.2 Functional elements
4.2.1 RCAF
The RCAF is a functional element which reports network status to the SCEF to enable the SCEF to take the RAN user
plane congestion status into account. The network status includes the following information;
- Congestion level or an indication of the "no congestion" state;
- ECGI, or eNB-ID, or SAI for which the congestion level is being provided.
4.2.2 SCEF
The SCEF is a functional element which provides a means to securely expose the services and capabilities provided by
3GPP network interfaces.
Based on the geographical area provided by the SCS/AS and the configuration data, the SCEF determines from which
RCAF(s) to request congestion reporting.
NOTE: The procedures in 3GPP TS 23.682 [2], subclause 5.8, describe the interaction between the SCEF and
SCS/AS and the information elements exchanged in the relevant steps of each procedure. When the SCEF
receives the network status information from one or more RCAF(s) in both the one-time or continuous
reporting cases, it determines the Network Status Indication (NSI) of the geographical area based on the
Congestion–Level-Value AVP in the Network-Congestion-Area-Report AVP it receives from the
RCAF(s). The NSI value (e.g. High, Medium, Low, No-Congestion) is determined per Service Provider
policies.
4.3 Procedures over the Ns reference point
4.3.1 Network status reporting procedures
4.3.1.1 General
This clause contains the detailed procedures for:
- Requesting one-time or continuous network status report ;
- Continuous reporting of network status;
- Cancellation of continuous reporting of network status.
4.3.1.2 Request of one-time or continuous reporting of network status
This procedure shall be used by the SCEF to request one-time or continuous network status report.
This procedure is mapped to Network-Status-Request /Answer commands specified in subclause 5.6.
After the SCEF authorized a SCS/AS request for notification about the network status, the SCEF shall assign an SCEF
Reference ID and identify the RCAF(s) responsible for requesting of the network status report. The identity of the
RCAF is found by the SCEF based on the RCAF selection procedure defined in subclause 4.3.2. If multiple RCAFs
have been found, the procedure shall be invoked multiple times, for each RCAF responsible for the network status
report.
The SCEF shall send a Network-Status-Request (NSR) command to the targeted RCAF. The NSR shall include the Ns-
Request-Type AVP with the value 0 (initial request), the SCEF reference ID within SCEF-Reference-ID AVP and the
location area in the Network-Area-Info-List AVP, the location area is either a 3GPP location area (e.g. list of TA/RAs,
list of cell(s), list of eNBs etc) according to operator configuration or a 3GPP location area (e.g. list of TA/RAs, list of
cell(s), list of eNBs etc) as provided by the SCS/AS.
The SCEF may also include duration in the Monitoring-Duration AVP and the threshold value(s) in Congestion-Level-
Range AVP if the SCS/AS requested reporting for specific threshold(s). The duration indicates the time for which a
ETSI
3GPP TS 29.153 version 14.3.0 Release 14 8 ETSI TS 129 153 V14.3.0 (2019-10)
continuous reporting is requested.
The SCEF, based on operator policies, may choose a different threshold value than the one received from the SCS/AS.
The SCEF shall not include the Congestion-Level-Range AVP in the request to the RCAF if no threshold was requested
by the SCS/AS.
NOTE: The SCS/AS can be notified when the SCEF changes the threshold provided by the SCS/AS.
If the continuous reporting is requested, the SCEF shall include the SCEF Id in the SCEF-ID AVP in the NSR
command.
Upon reception of a Network-Status-Request (NSR) command including the Ns-Request-Type AVP with the value 0
(initial request), the RCAF shall send the Network-Status-Answer (NSA) command to the SCEF including the SCEF-
Reference-ID AVP and one or more congestion status(es) within Network-Congestion-Area-Report AVP(s). If the
Monitoring-Duration AVP is present in the NSR, the RCAF shall store the SCEF Id and the SCEF instruction, and then
start to monitor the location area for a change in the congestion status.
When receiving NSA from the RCAF, the SCEF shall store the report if the SCS/AS request identified via the SCEF
reference ID is valid and active.
4.3.1.3 Continuous reporting of network status
This procedure shall be used by the RCAF to continuously notify the SCEF of the congestion status list for the location
area requested by the SCEF when at least one of the following conditions applies:
- a threshold is not provided by the SCEF and the congestion level(s) is changed;
- one or more thresholds are provided by the SCEF and the congestion level(s) is changed which corresponds to
the threshold(s) provided.
This procedure is mapped to Network-Status-Continuous-Report-Request/Answer commands specified in
subclause 5.6.
If one or more thresholds was provided to the RCAF by the SCEF, and when the RCAF detects a change in the
congestion level(s) and this congestion level(s) corresponds to congestion threshold(s) for the location area (e.g. set of
cells or eNodeBs) requested by the SCEF, the RCAF shall send Network-Status-Continuous-Report-Request (NCR)
command to report this to the SCEF.
The NCR command shall include SCEF reference ID within the SCEF-Reference-ID AVP and congestion status within
one or m
...

Questions, Comments and Discussion

Ask us and Technical Secretary will try to provide an answer. You can facilitate discussion about the standard in here.

Loading comments...